Volkswagen GTI Forums - My Fast GTi banner
1 - 2 of 2 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
06 Mark 5 gti. 140k (I know). Decided to try raceland ultimo coils, been on for 10k or so. Yesterday I replaced both drive Axles and upper strut mounts and bearings. Went smoothly aside from the sway bar links being a major pita. I stripped my m6 on the passenger side link, driver side like cracked loose so easy it scared me. No need for m6 trip square at all. After stripping the m6 I vise gripped the opposing side of the link to try to get grip to removed (again, I know). I ripped the rubber cuz it immeadatly spun. Got a new m6 and tightened up with not much force bc didn't wanna strip it again. EVERYTHING is tight I went over the whole **** like 4 times. No prior similar noises. Question is is is it possible to destroy a sway bar link w vise grips and some tool abuse to the point it will instantly start knocking? Symptoms are knocking over bumps, predominantly from side with said ****ty sway bar link, still have knocking from middle and driver side, I hear 1 loud pop if I turn the wheel from all the way one way to the other way. No humming or scratching or drivability difference I can notice since I haven't beat on her yet due to new drive shafts. Please help guys. This my baby!
 

·
Premium Member
Joined
·
5,926 Posts
06 Mark 5 gti. 140k (I know). Decided to try raceland ultimo coils, been on for 10k or so. Yesterday I replaced both drive Axles and upper strut mounts and bearings. Went smoothly aside from the sway bar links being a major pita. I stripped my m6 on the passenger side link, driver side like cracked loose so easy it scared me. No need for m6 trip square at all. After stripping the m6 I vise gripped the opposing side of the link to try to get grip to removed (again, I know). I ripped the rubber cuz it immeadatly spun. Got a new m6 and tightened up with not much force bc didn't wanna strip it again. EVERYTHING is tight I went over the whole **** like 4 times. No prior similar noises. Question is is is it possible to destroy a sway bar link w vise grips and some tool abuse to the point it will instantly start knocking? Symptoms are knocking over bumps, predominantly from side with said ****ty sway bar link, still have knocking from middle and driver side, I hear 1 loud pop if I turn the wheel from all the way one way to the other way. No humming or scratching or drivability difference I can notice since I haven't beat on her yet due to new drive shafts. Please help guys. This my baby!
My opinion is that if you lowered it too much you sway bar is rubbing on the axle. I did not lower my car that low with the kw V3 and it did the same thing. Also look at you strut mounts on top. The nut that holds the shock to the strut kount might be loose. Also done that a few times. Use an impact on it to get that nut nice and tight

Sent from my SCH-I535 using Tapatalk 2
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top