Volkswagen GTI Forums - My Fast GTi banner

1 - 8 of 8 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter · #1 ·
Got the REVO 5-Hour trial installed today. Figured I'd give it a trial before the programming would be wiped out anyways by an ECU update.

First reactions were: FUCK FUCK FUCK, POS ISN'T SHIFTING! (when over ~2000-2500 rpm)

I got the programming done and left the shop to go grab some more gas. As I made the first turn I knew something was wrong. I would give it gas and it would want to shift, but it seemed like it cut throttle/went neutral. So I grab the gas and head back to the shop very disappointed. I thought it may have been DSG adaption, but it seemed much more pronounced then that would be. I went back in the shop and the guy was very surprised. He checked fault codes and there was one in regards to missing transmission message or something along those lines. He tried the car and was, "yup, something wrong here". He went back into the settings of the REVO after making a call and turns out it was set to 0 0 0 for the settings. Whoops! So he enters the values Revo told him to use and all is fixed! He told me the mistake happened because of them being used to MK4's and the settings are unchangeable where on the MK5, they seem to flash unset at 0 0 0.

Second reactions were: Oooohhh yeah, this is nice. You can hear the boost even with the stock setup.
I'm waiting for a better time of day to test it all out as it was ~4:00pm and the roads were getting busy. I'll have more reactions after the freeway.

He also coded the windows via Vag-Com so I could roll them down with the key while he was in there with the cable. Very nice of him even though I could have done it as I have the cable :) Just a good way to make someone happy after the inconvenience of messing up the settings I guess.

I'll post again in a day when I get a chance on the freeway and empty streets. But you can feel the difference in pull.
 

·
Registered
Joined
·
280 Posts
Nice, glad that worked out for you. Did you feel a significant gain in pull? And at what speeds (i.e. from a stop, on the interstate, etc.).
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #3 ·
It was really busy out after I got it so haven't had time to try the upper end but it sure did gain pull. I can feel myself being pushed into the seat more and longer. I have a VAG-COM cable so I will get around to doing some tests and block logging.

I'm guessing also it was the 93 Octane program as they suggested I run nothing under 91.

From a stop, tires sure want to spin more.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #4 ·
Greeeaaaaatttt... Some bad news... Looks like the flash they used makes it appear my car already has the OY update (it does not).

So now when I goto the dealer it will be fun explaining why it looks like it has the update, but does not.

The place that did the programming is going to call back in an hour and let me know what my dealer says about this. (at least the tuner is 'friends' with the dealer manager)

and WOW, they actually said that chipping will NOT void my warranty as they work closely with my dealer and the 'performance' options they sell at my dealer actually come fromt this performance shop. We'll see by how much hell I'm put through ;)
 

·
Premium Member
Joined
·
4,311 Posts
nitroburn said:
Greeeaaaaatttt... Some bad news... Looks like the flash they used makes it appear my car already has the OY update (it does not).

So now when I goto the dealer it will be fun explaining why it looks like it has the update, but does not.

The place that did the programming is going to call back in an hour and let me know what my dealer says about this. (at least the tuner is 'friends' with the dealer manager)

and WOW, they actually said that chipping will NOT void my warranty as they work closely with my dealer and the 'performance' options they sell at my dealer actually come fromt this performance shop. We'll see by how much hell I'm put through ;)
I was in the same boat last week... I'm not sure exactly what they had to do, but they had to "work" with REVO over the issue. They originally said that I did not have the right flash and that I had to go to the dealer to get a flash upgrade. I called my dealer and this nice young lady who works at the shop called her friend at another dealer. Both dealerships said there were no updates.

I'm pretty impressed with the REVO (and the neuspeed exhaust) so far ;D
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #6 ·
Well, looks like I may be in luck and able to avoid the dealer breathing down my neck about my car saying I have the OY update when I don't.

The place that did the Revo flash contacted Revo and they are sending over an old version to be flashed over top that will return the updates back to the previous revision and I can take it in to get updated to OY at VW then go back and get it chipped properly.


Now I'm debating one thing...

Revo: CAD$675
APR: CAD$798.75 (regular: CAD$960 for 2 programs)

But also factor in the fact if I want to switch between Revo 93 & Stock I need a SPS 1 at least which is $269.78 CDN to make Revo CAD$944.78

Either I get the Revo program, or for a bit more I can get TWO APR programs. (Stock & 91)
I keep being told also that REVO & GIAC run too rich and can lead to problems down the road. Also, VW themselves picked APR, so that has to say something. Only think about the APR vs REVO is the APR I have to goto a shop 30min away vs the Revo which is a 5min drive a few blocks away.

I like the close factor of the Revo dealer, but I don't think that should be why I get Revo.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #7 ·
Dragon said:
I was in the same boat last week... I'm not sure exactly what they had to do, but they had to "work" with REVO over the issue. They originally said that I did not have the right flash and that I had to go to the dealer to get a flash upgrade. I called my dealer and this nice young lady who works at the shop called her friend at another dealer. Both dealerships said there were no updates.

I'm pretty impressed with the REVO (and the neuspeed exhaust) so far ;D
In my case REVO is sending over their old flash PRE-OY update and they are just going to flash it again so when I goto the dealer to get updated to OY I won't have to deal with a whole bunch of crap as their computers will say I'm already updated.

They SHOULD have told me to get OY first as they were adding the OY based chip, but I don't think the lady that flashed it knew this. Even though I stressed the point that I was doing the 5-Hour trial because I had yet to be flashed to OY.

They gave me the wrong flash, AND IT WORKED! But I need to be reverted to avoid headaches at the dealer.

-edit-
There IS an update. OY

Your dealer should have flashed your GTI with it when you go in to get serviced. I haven't gone in for my first service yet, and as such, had no update.

You should make sure you get the OY update if you dont have it.
 

·
Premium Member
Joined
·
4,311 Posts
The REVO folks offered to reflash it for me if the OY update caused an issue...

If my dealership gives me any shit, I know of another dealer that is "performance" friendly.
 
1 - 8 of 8 Posts
Top