Volkswagen GTI Forums - My Fast GTi banner

1 - 4 of 4 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
The other day it was raining and the roads were wet, i never beat on my car so i did a little burn out while it was wet. Right after i did it the idle was jumping from 700 to 2000 up and down and wouldnt stop. Also had it had like no boost and check engine light came on. Looked under the hood and the oil cap extension was completely broken off just sitting on top of the valve cover. i put the oil cap directly on the valve cover and it seems to run fine now. Do you guys think i could have messed something up, like ruptured the wastgate diaphragm or messed up the turbo seals or something?? The CEL didnt go off yet, obviously, but im a little sketched out and nervous to drive it. What do you think?
 

·
Super Moderator
Joined
·
3,120 Posts
Well first it is not a big deal that the filler neck came off. Its just glued on. Also, Since the car was running and the neck broke off then it is meant to do that. If you go and take the oil cap off right now when your car is running then it will do the same thing. The CEL may go away but if not then get it scanned by someone to see what the code is that it gives. O0
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #4 ·
i scanned it today and got p0507 and p0920... the p0920 i know isnt really important but the code for the IAC deserves some attention, after i scanned it as soon as i started driving the CEL went off and been running great. gas milage went down about 3 mpg though. i drive 100+ miles a day so i know my average mileage. as for what i did to make this happen... gave it a lil gas in 1st to break tires loose in the rain and pop, instantly running like garbage. You guys think im ok now tho? sry im just paranoid when it comes to my baby
 
1 - 4 of 4 Posts
Top