My Fast GTi banner

1 - 11 of 11 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
okay guys the edited tools required to make it easier on yourself is following.

1/4 inch ratchet 2 inch extension and a 5mm allen socket or if you have bits for a screwdriver, one of those adapter thingys. MUCH faster than allen keys! gtfly you have this? loc-tite is also required.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #6
i ended up installing it at the shop for 65. It's a very nice piece, only noticed a increase of 1-3 psi at red line but at peak it's the same unless your oem is leaking. O0
 

·
Premium Member
Joined
·
4,311 Posts
OK- I had the shop (Genesis) do mine today.

Took them about an hour. I warned them it's a tight fit and to measure the hoses twice. No major issues with the install and provided instructions from Forge.

Here is what's sorta funny... when I had the NS CAI put on- it made this strange raspy sound on acceleration. 22350 suggested it was my DV screaming, I'm about to blow! I think he was correct :eek:. I haven't taken the old DV apart to inspect the diaphragm, but I suspect it was leaking for the past few weeks. The raspy sound is GONE. :)

Boost is up and the response is noticeable. It's fun when a beemer guy says "I want your car" ;D

Also had the H&R rear sway bar put in, but haven't really had a chance to test it. A friend of mine is coming over tomorrow and she's gonna hold my notebook PC during a data-logging run... I wanna baseline the engine before doing the stage II upgrade on the chip. >:D
 

·
Registered
Joined
·
1,064 Posts
Dragon said:
OK- I had the shop (Genesis) do mine today.

Took them about an hour. I warned them it's a tight fit and to measure the hoses twice. No major issues with the install and provided instructions from Forge.

Here is what's sorta funny... when I had the NS CAI put on- it made this strange raspy sound on acceleration. 22350 suggested it was my DV screaming, I'm about to blow! I think he was correct :eek:. I haven't taken the old DV apart to inspect the diaphragm, but I suspect it was leaking for the past few weeks. The raspy sound is GONE. :)

Boost is up and the response is noticeable. It's fun when a beemer guy says "I want your car" ;D

Also had the H&R rear sway bar put in, but haven't really had a chance to test it. A friend of mine is coming over tomorrow and she's gonna hold my notebook PC during a data-logging run... I wanna baseline the engine before doing the stage II upgrade on the chip. >:D
I hate you.... a lot...

OK, not really....but the level of jealousy is preeeeety f'n close to hate.
 

·
Premium Member
Joined
·
4,311 Posts
22350 said:
I hate you.... a lot...

OK, not really....but the level of jealousy is preeeeety f'n close to hate.


Dude- it's sweet!!! Wanna buy a slightly used C valve? ;D

+ I installed the TMtuning vented foglight covers. They come with a scoop that directs the air right to the filter on the CAI- I just have to get some kind of screening material to keep the larger debris off the filter; Home Depot- here I come... >:D

Don't feel bad Nigel- my AWE vent guage is on back order...
 
1 - 11 of 11 Posts
Top