Volkswagen GTI Forums - My Fast GTi banner
1 - 17 of 17 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Just brought my 06 for it's annual inspection and it failed for two things. The check engine light had just recently come on (at first I thought it was for a light out) and it turns out it was for under boost. The code that came up was P0299. Has anyone gotten this code? If so what turned out to be the problem and how expensive was it?

The other reason it failed was that the rear center brake light was out. Is this most likely the bulb or possibly wiring?
 

·
Premium Member
Joined
·
8,973 Posts
Just brought my 06 for it's annual inspection and it failed for two things. The check engine light had just recently come on (at first I thought it was for a light out) and it turns out it was for under boost. The code that came up was P0299. Has anyone gotten this code? If so what turned out to be the problem and how expensive was it?

The other reason it failed was that the rear center brake light was out. Is this most likely the bulb or possibly wiring?
problem #1

probably a torn DV. Upgrade to the revision D here:

http://www.ecstuning.com/Volkswagen-Golf_V--2.0T/Search/Diverter/ES263879/

crawl up under it and look at the part number on your current DV, if it does not have a "D" at the end it is not the updated one. you can also pull it out by removing the 3 bolts and uncliping the wire connector to inspect the diaphram for rips.

problem #2

Those center brake lights are mounted inside the "wing" some of them had a tendency to allow water to enter the housing shorting out the light. the bad news here..
It is my understanding the wing must be removed and the light housing replaced, a pretty expensive fix because the wing is held on with adhesive not bolts, which means it must be glued back on with the industrial glue crap they use. The light housing isn't cheap either.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #3 ·
Okay thanks I'll look at the DV.
Great. Hopefully the brake light will be something simple but that's probably the issue especially since we have had a lot of snow so it's very likely moisture got in there.
 

·
I'm Watching You
Joined
·
15,550 Posts
i thought there was a recall or at least a TSB on those 3rd brake lights

but im not sure, i dont have a mk5
 

·
Premium Member
Joined
·
8,973 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
41 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
41 Posts
Discussion Starter · #10 ·
I can't find the part number anywhere on the dv. Anyone got tips?
 

·
Premium Member
Joined
·
3,622 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #12 ·
No I am trying to figure out if my current one is the stock one or has the d at the end of the number and is the updated one. I can't find the part number anywhere on the dv in my car
 

·
Premium Member
Joined
·
3,622 Posts
It's on the side of the valve itself. You're probably going to have to pull it out to check.
 

·
Premium Member
Joined
·
3,622 Posts
If you still can't see the number, the revision D is on the left in this picture and all previous versions are the diaphragm style on the right.

 

·
Registered
Joined
·
41 Posts
Discussion Starter · #15 ·
Okay thanks. Looks like I'll be pulling it out tomorrow
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #16 ·
So I just got my car back from having the brake light replaced. The engine light is now off and it feels like I have my turbo back. He didn't mention anything about it at the dealership. Is it fixed? At first I figured they just turned the check engine light off, but after pushing it a little it really doesn't feel like it did before. My torque seems like it's back
 

·
Premium Member
Joined
·
8,973 Posts
So I just got my car back from having the brake light replaced. The engine light is now off and it feels like I have my turbo back. He didn't mention anything about it at the dealership. Is it fixed? At first I figured they just turned the check engine light off, but after pushing it a little it really doesn't feel like it did before. My torque seems like it's back
check your paperwork and see what all they did, they give you a print out of everything they did.

Sometimes resetting the light will make things better for a little bit, then when the ecu senses the problem again it could go back to the way it was.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top